RIA crumbs.

Blog about RIA development. ActionScript, JavaScript and more.

Головная боль при скиновании во Flex 3 от Adobe

leave a comment

В процессе глубокого дебага скинов на проекте с использованием Flex 3 поймал грабли на том, что к примеру границы у PanelTitle не хотел быть как и прежде и Accordion не “поднимает” значения атрибута selectedFillColors. Если честно была озадаченность в мозгах и поиски каких-то косяков с нашей стороны, но все оказалось намного проще, на первый взгляд :)

Оказывается что Adobе, в процессе изменения SDK для Flex 3, решили добавить флаг для компилятора -compatibility-version, указав который мы насильно заставляем наше Flex приложение, разработанное с использованем SKD для Flex 3, использовать поведение некоторых UI компонент из старого доброго SDK 2.0.1 :) На Adobe Labs есть описание флага и различий между SDK, а также заметки о том где пользователь наступит на грабли.

Вот такие пироги…

Written by reijii

January 16th, 2008 at 4:43 pm

Leave a Reply